eslint-plugin-standard

ESlint Plugin for the Standard Linter

standard 16.0.0 and eslint-config-standard 16.0.0 no longer require the eslint-plugin-standard package. You can remove it from your dependencies with 'npm rm eslint-plugin-standard'. More info here: https://github.com/standard/standard/issues/1316
Last updated a year ago by feross .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install eslint-plugin-standard 
SYNC missed versions from official npm registry.

eslint-plugin-standard travis npm downloads javascript style guide

Deprecated: This package isn't used by standard anymore, as of standard v16. See: https://github.com/standard/standard/issues/1316

ESlint Rules for the Standard Linter

Usage

npm install --save-dev eslint-plugin-standard

Configuration

module.exports = {
  rules: {
    'standard/object-curly-even-spacing': [2, 'either'],
    'standard/array-bracket-even-spacing': [2, 'either'],
    'standard/computed-property-even-spacing': [2, 'even'],
    'standard/no-callback-literal': [2, ['cb', 'callback']]
  }
}

Rules Explanations

There are several rules that were created specifically for the standard linter.

  • object-curly-even-spacing - Like object-curly-spacing from ESLint except it has an either option which lets you have 1 or 0 spaces padding.
  • array-bracket-even-spacing - Like array-bracket-even-spacing from ESLint except it has an either option which lets you have 1 or 0 spacing padding.
  • computed-property-even-spacing - Like computed-property-spacing around ESLint except is has an even option which lets you have 1 or 0 spacing padding.
  • no-callback-literal - Ensures that we strictly follow the callback pattern with undefined, null or an error object in the first position of a callback.

Current Tags

  • 5.0.0                                ...           latest (a year ago)

22 Versions

  • 5.0.0 [deprecated]           ...           a year ago
  • 4.1.0                                ...           a year ago
  • 4.0.2                                ...           a year ago
  • 4.0.1                                ...           2 years ago
  • 4.0.0                                ...           3 years ago
  • 3.1.0                                ...           3 years ago
  • 3.0.1                                ...           5 years ago
  • 3.0.0                                ...           5 years ago
  • 2.3.1                                ...           5 years ago
  • 2.3.0                                ...           5 years ago
  • 2.2.0                                ...           5 years ago
  • 2.1.1                                ...           5 years ago
  • 2.1.0                                ...           5 years ago
  • 2.0.1                                ...           5 years ago
  • 2.0.0                                ...           5 years ago
  • 1.3.3                                ...           5 years ago
  • 1.3.2                                ...           6 years ago
  • 1.3.1                                ...           6 years ago
  • 1.3.0                                ...           6 years ago
  • 1.2.0                                ...           6 years ago
  • 1.1.0                                ...           6 years ago
  • 1.0.0                                ...           6 years ago
Downloads
Today 9,001
This Week 49,468
This Month 170,151
Last Day 13,268
Last Week 74,753
Last Month 324,914
Dependencies (0)
None
Dev Dependencies (3)
Dependents (2060)

Copyright 2014 - 2021 © npmmirror.com |